F-Secure Safe - 1 Year Full Licence for 3 PCs, Retail

Sale price £30.00 Regular price £60.00

Tax included.
Protect your life on every device

F-Secure SAFE is an award-winning internet security suite which protects you from viruses, trojans and ransomware. SAFE also secures your online banking connection. You can set limits for internet usage for children. You and your family can surf safely both on desktop and mobile.

Antivirus
Keep your devices safe from viruses, trojans, ransomware, adware, keyloggers, spyware, and other malware.

Browsing and Banking Protection
Browsing protection keeps you safe from harmful and dangerous web pages to ensure your security and privacy. Banking protection lets you know when you enter a safe banking site and secures the connection to the site, keeping your money safe.

Device Finder
It's easy to check the location of your phone in the My F-Secure service. On Android, you can also lock a lost device or delete all your information to prevent other people from accessing your personal files, like photos and emails.

Parental Control
Children spend a lot of time online. Set boundaries and look after your family's well-being by setting screen time limits and blocking access to websites based on the site content: adult, violence, shopping, gambling, social media, etc.

My F-Secure Account
Easy and convenient way to manage all protected devices from one place. Protect new devices, renew your subscriptions, and change your payment options.

System Requirements
PC
Platforms: Windows 10, Windows 8.1, Windows 7
Processor: Intel Pentium 4 or higher
Memory: 1GB or more
Disk space: 1.2GB free disk space
Internet connection to validate your subscription and receive updates. ARM based tablets are not supported. The system must fulfil Windows minimum requirements as specified by Microsoft.

MAC
Platforms: macOS 10.13 (High Sierra), macOS 10.12 (Sierra), OS X 10.11 (El Capitan)
Processor: Intel
Memory: 1GB or more
Disk space: 250 MB free disk space

Smartphones and Tablets
Platforms: Android 5 or later, iOS 10 or later